Back to overview
Degraded

Products.API is down

Jun 1, 2026 at 4:04pm UTC
Affected services
Products.API

Resolved
Jun 1, 2026 at 4:17pm UTC

Products.API recovered.

Created
Jun 1, 2026 at 4:04pm UTC

Products.API is degraded.